Menu
Game System Requirements Google+ profile
Game System Requirements Google+ profile
Game System Requirements Google+ profile
Game System Requirements Facebook profile
Overlord
Overlord
Datum vydání: 2007. červen 26. (PC)
Sys. Reqs.: Very low (2)
Popularita: ~2290# ■
Értékelések átlaga: 8.8
Žánr: Action, Role-playing game
Vývojář: Triumph Studios, Virtual Programming
Vývojář: Codemasters
iThere are only official system requirements on the site which are released by developers or an official publisher.
Minimální požadavky:
Doporučené požadavky:
CPU:
Pentium 4 2.4 GHz or Athlon XP 2400+
CPU:
Intel Core 2 Duo or Athlon 64 X2
RAM:
512MB RAM
RAM:
1GB RAM
GPU:
GeForce FX5900 / Radeon 9500 or above
GPU:
GeForce 7800 or Radeon X1800
DX:
DirectX 9c
DX:
DirectX 9c
OS:
Microsoft(R) Windows(R) XP http://systemreqs.com/cz/
OS:
Microsoft® Windows® XP/Vista
Store:
4.5 GB available
Store:
4.5 GB available
Zvuk:
DirectX compatible sound card
Poznámka: Multiplayer is no longer available. SUPPORTED GRAPHICS CARDS ATi Radeon: 9500, 9600, 9700, 9800, X300, X600, X700, X800, X1300, X1600, X1800, X1900, X1950 nVidia: GeForce FX5900, FX5950, 6600, 6800, 7100, 7300, 7600, 7800, 7900, 7950, 8800 Not compatible with all integrated sound/graphics solutions (inc. Laptops)
Comparison:
Compare the system requirements with a configuration added by you.
Podobné hry:
The Mage's TaleDark Souls IIIYs VIII: Lacrimosa of DANADragon Quest HeroesS.T.A.L.K.E.R. Clear SkyGrim DawnTales of BerseriaValkyria Chronicles
Databáze