Menu
Game System Requirements Google+ profile
Game System Requirements Google+ profile
Game System Requirements Google+ profile
Game System Requirements Facebook profile
Overlord II
Overlord II
發售日: 2009. 六月 23. (PC)
Sys. Reqs.: Very low (4)
聲望: ~1060# ■
Értékelések átlaga: 9.0
類型: Role-playing game
開發人員: Triumph Studios, Virtual Programming
發行商: Codemasters
iThere are only official system requirements on the site which are released by developers or an official publisher.
最低系统需求:
CPU:
Pentium 4 3.0Ghz/Athlon 64bit 3000+
RAM:
1 GB
GPU:
GeForce 6800+/ATI X1600+ with 256MB
DX:
DirectX 9.0c
OS:
Windows XP SP2+ http://systemreqs.com/cn/
Store:
5GB
声音:
DirectX Compatible Sound Card
注意: Multiplayer is no longer available
Comparison:
Compare the system requirements with a configuration added by you.
相似:
Dark Souls (Prepare to Die Edition)Conan ExilesOsiris: New DawnBattle Chasers: NightwarThe TechnomancerARK: Survival EvolvedDungeon Siege IIIDark Souls II
数据库